Insecure POP servers

Sparrow 1.3 fails to connect to POP servers that do not provide SSL connection. We'll fix that issue in an incoming update (1.3.1).